Can not save document back into document library

I recently came across an error when I attempted to create and save a new document in a SharePoint 2010 document library.

1. I went to the document library

2. Clicked on New Document

3.  Typed in some text into the word document.

4. Clicked on Save

5. A dialog box appears asking for a save location onto a drive on my local computer

6. I can not save the file back into the document library where I clicked on New Document

Solution

How I got this fixed was by enabling the WebClient Service in Window services (services.msc). To install this feature:

1. Go to Server Manager

2. Right click on Features node in the tree view

3. Select Add Feature

4. Select Desktop Experience

5. Click Next on the next screens and finally click Install.

6. Reboot computer.

7. Open up Window Services and check the WebClient service is available, enabled and started.

Go to your SharePoint document library, and create a New Document. Enter some text and click Save.

I am now able to save documents back to their place of origin, i.e. the document library where I clicked on New Document.

Side Note

I have read on some forums that tell users to implement this (http://support.microsoft.com/kb/870853) to fix this issue but it sure did not fix it for myself, plus it is also address SharePoint 2003/2007 and not 2010.

Advertisements

Visual Studio 2010 Can’t open new SPSite object

Using Visual Studio 2010, I come across an FileNotFoundException when creating a WPF application. The exception happened with the below snip of code:

using(SPSite  site = new SPSite(“http://phillau”))

I read another post that told me to run Visual Studio 2010 with Administrator privileges so I did. It did not fix the problem.

So I went into the csproj properties and checked out what platform my project was targeted at. I changed it from x86 to x64 because I was working in a x64bit environment. Then I came across a PlatformNotSupportedException.

I went into the csproj properties again and changed the .Net version from 4 to 3.5. .Net 4 has not been deployed to in my work environment.

Rebuilt the project and SUCCESS 🙂

Specs

  1. OS: Windows Server 2008 R2
  2. SharePoint 2010
  3. Visual Studio 2010

Turn off Enhanced Security Configuration in Windows Server 2008

This is how I turned it off:

Open Server Manager, select the Server Manager node (yes, the root node of that navigation tree)

In the Server Summary window, go to the Security Information tab

On the right hand side of the screen, select Configure IE ESC

Select Off for both Administrators and Users (This is totally up to you to decide what is best in your situation)

Select Ok to proceed.

Close any existing Internet Explorer windows are open and open new Internet Explorer windows.

Done.